めも:Xcode 5.1 が入った後に gem install(bundle update/install)ができない

Xcode5.1がインストールされたMacの環境でgem installなどを行おうとすると、llvmの仕様変更により(native extensionをつかっているものは)コンパイルエラーが発生するっぽい。

ERROR: Failed to build gem native extension

linking shared-object json/ext/generator.bundle
clang: error: unknown argument: '-multiply_definedsuppress' [-Wunused-command-line-argument-hard-error-in-future]

的なのがでたら

ARCHFLAGS=-Wno-error=unused-command-line-argument-hard-error-in-future bundle update[などの任意のコマンド]

で対応.

References:
http://stackoverflow.com/questions/22352838/ruby-gem-install-json-fails-on-mavericks-and-xcode-5-1-unknown-argument-mul

そのうちなおる
https://bugs.ruby-lang.org/issues/9624


コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

次のHTML タグと属性が使えます: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Post Navigation